Back to overview
Degraded
Email Issues (Microsoft 365)
Jul 18 at 09:39am BST
Affected services
Microsoft 365
Resolved
Jul 20 at 08:00am BST
Now working as expected
Affected services
Updated
Jul 18 at 10:51am BST
Update from Microsoft:
We’ve disabled an interceptor rule that we believe was causing impact to the mail flow. We’re monitoring the service to ensure the mail flow is restored.
Affected services
Created
Jul 18 at 09:39am BST
Hello, Please be aware there are currently issues with sending/recieving mail in Microsoft 365
The issue is with some backend server problems within the Microsoft ecosystem
Once we know more we will update further.
Affected services